Topics

rest-client 1.6.8 and 1.7.0 released

Andy Brody <andy@...>
 

The first new releases of REST Client in quite some time are now
available on RubyGems!

Please find the changelog on GitHub at
https://github.com/rest-client/rest-client/blob/v1.7.0/history.md

On the 1.6.x branch, the 1.6.8 release represents three years worth of
sundry cleanup and test improvements. Tests now run for the major
branches on Travis CI. This branch is now in maintenance-only mode,
and it will be the last line of releases to support Ruby 1.8.7, which
is itself very much on the way out.

The 1.7.0 release contains a variety of new minor features especially
related to SSL support, and breaks backwards compatibility in a few
minor ways:

- From rest-client >= 1.7.0, support for Ruby 1.8.7 has been dropped.
This allowed an upgrade to mime-types 2.0. For continued Ruby 1.8.7
support, please use releases in the 1.6.x series and pin your
dependencies to '~> 1.6.8'.

- For HTTPS connections, SSL peer verification is now *enabled* by
default. We have made an effort to make rest-client behave much more
like browsers by choosing secure defaults. Rest-client will check
certificates against the system-provided certificate authorities on
Linux, OS X, and Windows. It will also attempt to select a strong set
of SSL cipher suites. And there are several new configuration options
for advanced usage including SSL ca_path, cert_store, and
verify_callback parameters.

In order to support the Windows system CA store, there is now a
separate build for Windows that pulls in the `ffi` gem.

These releases represent years of work from a very large number of
contributors, but thanks especially belong to Larry Gilbert and Matt
Manning for all their work.

We aim to pick up the pace of development now that the long freeze on
releases has thawed! Please submit your pull requests on GitHub:
https://github.com/rest-client/rest-client/pulls

Warmly,
Andy